POJ 1125. Stockbroker Grapevine

1. 题目

http://poj.org/problem?id=1125

Stockbroker Grapevine
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 31786 Accepted: 17416

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way.

Unfortunately for you, stockbrokers only trust information coming from their “Trusted sources” This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a ‘1’ means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules.

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people.

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes.
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message “disjoint”. Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10

Source

2. 思路

在股票经纪人之间传播谣言,给出各个经纪人的联系人和联系耗时,要在最短的时间内将谣言传遍所有人,求谣言应从谁开始传播,以及传遍所有人的耗时。

使用Floyd算法求带权有向图任意两点间的最短距离,找出到达所有点的距离之和最小的那个点,即为所求。

3. 代码

#include <cstdio>

#define MAX_N 101
#define MAX_TIME 10000

typedef int Cost[MAX_N][MAX_N];

void solvePE8a_StockbrokerGrapevine();
int input(Cost c);
void floyd(Cost c, int n);

int main() {
	// freopen("test.txt", "r", stdin);
	solvePE8a_StockbrokerGrapevine();
	return 0;
}

Cost cost;
void solvePE8a_StockbrokerGrapevine() {
	while (1) {
		int n = input(cost);
		if (n == 0) {
			return;
		}
		floyd(cost, n);
	
		int min = MAX_TIME, select = 0, disjoint = false;
		for (int i = 1; i <= n; ++i) {
			int cand = 0;
			disjoint = false;
			for (int j = 1; j <= n; ++j) {
				if (i != j) {
					if (cost[i][j] == MAX_TIME) {
						disjoint = true;
						break;
					}
					cand = cand > cost[i][j] ? cand : cost[i][j];
				}
			}
			if (!disjoint && min > cand) {
			min = cand;
			select = i;
			}
		}
		if (min == MAX_TIME) {
			printf("disjoint\n");
		} else {
			printf("%d %d\n", select, min);
		}
	}
}

int input(Cost c) {
	int n;
	scanf("%d", &n);
	
	for (int i = 1; i <= n; ++i) {
		for (int j = 1; j <= n; ++j) {
			c[i][j] = MAX_TIME;
		}
	}
	
	for (int i = 1; i <= n; ++i) {
		int contactNum;
		scanf("%d", &contactNum);
		for (int j = 1; j <= contactNum; ++j) {
			int contact, time;
			scanf("%d %d", &contact, &time);
			c[i][contact] = time;
		}
	}
	
	return n;
}

void floyd(Cost c, int n) {
	for (int k = 1; k <= n; ++k) {
		for (int i = 1; i <= n; ++i) {
			for (int j = 1; j <= n; ++j) {
				int cand = c[i][k] + c[k][j];
				c[i][j] = c[i][j] < cand ? c[i][j] : cand;
			}
		}
	}
}