POJ 1384. Piggy-Bank

1. 题目

http://poj.org/problem?id=1384

Piggy-Bank
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 9043 Accepted: 4413

Description

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it’s weight in grams.

Output

Print exactly one line of output for each test case. The line must contain the sentence “The minimum amount of money in the piggy-bank is X.” where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line “This is impossible.”.

Sample Input

3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

Sample Output

The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.

Source

2. 思路

给出空的和装满的存钱罐的重量E和F,其中装有N种硬币,第i种硬币质量为w[i],价值为p[i],求存钱罐中至少有多少钱。

每种物品可以使用多次,完全背包,要求正好装满。数据范围较大,使用二维数组实现会超内存,须使用一维数组实现。

使用f[j]表示使用前i种硬币达到重量j,所能得到的最小价值,存钱罐中钱币重量M = F – E,有:

f[0] = 0
f[1 : W] = MAX_WEIGHT
for i = 1 : N
    for j = w[i] : M
        f[j] = min(f[j - w[i]] + p[i], f[j])

注意题目要求正好装满背包,初始化选择前0件物品(i = 0)的状态时,f[0] = 0 表示对于容量为0的背包,一件物品都不选,价值为0是合法的;f[1 : W] = MAX_WEIGHT 表示对于容量不为0的背包,一件物品都不选无法正好装满背包,不合法。

j的循环是从w[i]到M,按照从小到大的顺序。在计算f[j] = min(f[j – w[i]] + p[i], f[j]) 时,f[j – w[i]] 刚在本轮i的循环中更新过,这样就考虑了重复选择第i中物品的情况。

3. 代码

#include <cstdio>

const int MAX_N = 10000 + 1;
const int MAX_WEIGHT = 0x0fffffff;

void solveE7a_PiggyBank();
void input(int p[], int w[], int n);

int main() {
    int tcNum;
    scanf("%d", &tcNum);

    while (tcNum--) {
        solveE7a_PiggyBank();
    }
}

int p[MAX_N], w[MAX_N], f[MAX_N];
void solveE7a_PiggyBank() {
    int empty, full;
    scanf("%d %d", &empty, &full);
    int weight = full - empty;

    int n;
    scanf("%d", &n);
    input(p, w, n);

    for (int i = 1; i < MAX_N; ++i) {
        f[i] = MAX_WEIGHT;
    }
    f[0] = 0;

    for (int i = 1; i <= n; ++i) {
        for (int v = w[i]; v <= weight; ++v) {
            int cand = f[v - w[i]] + p[i];
            f[v] = cand < f[v] ? cand : f[v];
        }
    }

    if (f[weight] != MAX_WEIGHT) {
        printf("The minimum amount of money in the piggy-bank is %d.\n", f[weight]);
    }
    else {
        printf("This is impossible.\n");
    }
}

void input(int p[], int w[], int n) {
    for (int i = 1; i <= n; ++i) {
        scanf("%d %d", &p[i], &w[i]);
    }
}