POJ 1064. Cable master

1. 题目

http://poj.org/problem?id=1064

Cable master
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 30585 Accepted: 6482

Description

Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a “star” topology – i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it.
To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible.
The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled.
You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.

Input

The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.

Output

Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point.
If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number “0.00” (without quotes).

Sample Input

4 11
8.02
7.43
4.57
5.39

Sample Output

2.00

Source

2. 思路

现有若干根长度不等的光纤,要把它们切割成为指定数量的等长光纤,求等长光纤的最大长度。

二分法。初始下界是0,上界是初始不等长光纤的最大长度,进行二分搜索。需要注意的是,题目的测测试例对精度有一定要求,如果直接使用double来存储输入数据,很可能会因为误差而导致WA,由于只要求精确到cm,下面给出的代码以cm为单位将长度存储为int。

3. 代码

#include <stdio.h>

#define MAX_N 10000

void solveE5a_CableMaster();
double inputCables(int cables[], int n);
bool fit(int cables[], int n, double len, int targetNum);

int main() {
	solveE5a_CableMaster();
}

int cables[MAX_N];
void solveE5a_CableMaster() {
	int n, k;
	scanf("%d %d", &n, &k);

	double max = inputCables(cables, n);
	int l = 0, r = max, mid = (l + r) / 2;

	while (l <= r) {
		if (fit(cables, n, mid, k)) {
			l = mid + 1;
		} else {
			r = mid - 1;
		}
		mid = (l + r) / 2;
	}

	printf("%.2f\n", mid * 0.01);
}

double inputCables(int cables[], int n) {
	int cm, m, max = 0;
	for (int i = 0; i < n; ++i) {
		scanf("%d.%d", &m, &cm);
		cables[i] = m * 100 + cm;
		max = cables[i] > max ? cables[i] : max;
	}
	return max;
}

bool fit(int cables[], int n, double len, int targetNum) {
	int num = 0;
	for (int i = 0; i < n; ++i) {
		num += cables[i] / len;
	}

	if (num >= targetNum)
		return true;
	else
		return false;
}