POJ 1463. Strategic game

1. 题目

http://poj.org/problem?id=1463

Strategic game
Time Limit: 2000MS Memory Limit: 10000K
Total Submissions: 7290 Accepted: 3379

Description

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

For example for the tree:


the solution is one soldier ( at the node 1).

Input

The input contains several data sets in text format. Each data set represents a tree with the following description:

  • the number of nodes
  • the description of each node in the following format
    node_identifier:(number_of_roads) node_identifier1 node_identifier2 … node_identifiernumber_of_roads
    or
    node_identifier:(0)

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500);the number_of_roads in each line of input will no more than 10. Every edge appears only once in the input data.

Output

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following:

Sample Input

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output

1
2

Source

2. 思路

防卫一座树形的城市,城市中的道路作为树的边,道路的交汇点作为树的节点。在节点上放置一名卫兵,可以防守与该节点相连的道路。求防卫所有道路,最少需要多少卫兵。

树形DP。对于树中的任意节点r:

  • 使用dp[r][0]表示不在r上放置卫兵时,防卫以r为根节点的子树,所需的最少卫兵数,此时需要在r的所有子节点上放置卫兵(dp[c][1]),才能防守r通向其所有子节点的道路;
  • 使用dp[r][1]表示在r上放置卫兵时,防卫以r为根节点的子树,所需的最少卫兵数,此时r的子节点c可以放置卫兵(dp[c][1]),也可以不放置(dp[c][0]),取决于dp[c][1]和dp[c][0]哪个较小。

即:

dp[0 : N - 1][0 : 1] = 0 
for each child c of r:
    dp[r][0] += dp[c][1]
    dp[r][1] += min(dp[c][0], dp[child][1])

3. 代码

#include <cstdio>

#define MAX_N 1500
#define IDX_NUM 0

typedef int Graph[MAX_N][11];
typedef int DP[MAX_N][2];

void solvePE8b_StrategicGame();
int input(Graph g, int n);
void dfs(int nodeIdAsRoot);
int min(int a, int b);

int main() {
	// freopen("test.txt", "r", stdin);
	solvePE8b_StrategicGame();
	return 0;
}

Graph graph;
DP dp;
void solvePE8b_StrategicGame() {
	int n;
	while (scanf("%d", &n) != -1) {
		int rootId = input(graph, n);

		dfs(rootId);

		int result = min(dp[rootId][0], dp[rootId][1]);
		printf("%d\n", result);
	}
}

void dfs(int nodeIdAsRoot) {
	int childNum = graph[nodeIdAsRoot][IDX_NUM];
	if (childNum == 0) {
		dp[nodeIdAsRoot][0] = 0;
		dp[nodeIdAsRoot][1] = 1;
		return;
	}
	else {
		dp[nodeIdAsRoot][0] = 0;
		dp[nodeIdAsRoot][1] = 0;
		for (int i = 1; i <= childNum; ++i) {
			int child = graph[nodeIdAsRoot][i];
			dfs(child);
			dp[nodeIdAsRoot][0] += dp[child][1];
			dp[nodeIdAsRoot][1] += min(dp[child][0], dp[child][1]);
		}
		++dp[nodeIdAsRoot][1];
	}
}

int min(int a, int b) {
	return a < b ? a : b;
}

bool isChild[MAX_N];
int input(Graph g, int n) {
	for (int i = 0; i < n; ++i) {
		isChild[i] = false;
	}

	for (int i = 0; i < n; ++i) {
		int id, num;
		scanf("%d:(%d)", &id, &num);
		g[id][IDX_NUM] = num;
		for (int j = 1; j <= num; ++j) {
			int leafId;
			scanf("%d", &leafId);
			g[id][j] = leafId;
			isChild[leafId] = true;
		}
	}

	for (int i = 0; i < n; ++i) {
		if (!isChild[i]) {
			return i;
		}
	}
	return -1;
}