POJ 3624. Charm Bracelet

1. 题目

http://poj.org/problem?id=3624

Charm Bracelet
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 28195 Accepted: 12696

Description

Bessie has gone to the mall’s jewelry store and spies a charm bracelet. Of course, she’d like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a ‘desirability’ factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

Source

2. 思路

使用N种符文强化负重为M的幸运手镯,每种符文重量为Wi,幸运值为Di,求在负重范围内所能获得的最大强化。

每种物品只能用一次,01背包问题;不要求装满背包,初始化为全0,即物品数多余1时,一个物品都不装也属于合法解。数据范围较大,使用二维数组实现会超内存,须使用一维数组实现。

使用f[j]表示使用前i个物品来装容量为j的背包所能获得的最大价值,使用w[i]表示第i个物品的重量,d[i]表示第i个物品的价值,有:

f[0 : N] = 0
for i = 1 : N
    for j = M : w[i]
        f[j] = max(f[j - w[i]] + d[i], f[j])

注意j的循环是从M到w[i],按照从大到小的顺序进行更新。这样在计算f[j] = max(f[j – w[i]] + d[i], f[j]) 时,f[j – w[i]] 还保留了上一个i循环的值,即没有选择第i个物品时的f[j – w[i]] ,在此基础上选择第i件物品后,背包新的价值为f[j – w[i]] + d[i] ,保证每件物品只选择一次。

3. 代码

#include <cstdio>

const int MAX_N = 3402 + 1;
const int MAX_W = 12880 + 1;

void solveE7a_CharmBracelet();
void input(int w[], int d[], int n);

int main() {
	solveE7a_CharmBracelet();
}

int f[MAX_W], w[MAX_N], d[MAX_N];
void solveE7a_CharmBracelet() {
	int n, m;
	scanf("%d %d", &n, &m);
	input(w, d, n);

	for (int i = 1; i <= n; ++i) {
		for (int j = m; j >= w[i]; --j) {
			f[j] = (f[j - w[i]] + d[i]) > f[j] ? (f[j - w[i]] + d[i]) : f[j];
		}
	}

	printf("%d\n", f[m]);
}

void input(int w[], int d[], int n) {
	for (int i = 1; i <= n; ++i) {
		scanf("%d %d", &w[i], &d[i]);
	}
}