POJ 3273. Monthly Expense

1. 题目

http://poj.org/problem?id=3273

Monthly Expense
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 18048 Accepted: 7226

Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called “fajomonths”. Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ’s goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers: N and M
Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

Source

2. 思路

给出N天中每天花费的钱数,要把N天划分为M个财政周期,每个周期包含若干(1天或更多)连续的天数。现在要为每个财政周期制定一个统一的消费上限,要求每个财政周期内各天的总消费不得超过这个上限,求财政周期消费上限的最小值。

对每周期消费上限进行二分搜索,按照当前消费上限,将N天划分为若干消费周期,如所得周期数量不大于M,则可行,继续降低消费上限,否则提高上限,直到找到符合条件的最小值。

3. 代码

#include <stdio.h>

#define MAX_N 100000

void solveE5c_MonthlyExpense();
int inputBudget(short budget[], int n);
bool inRed(short budget[], int n, int monthBudget, int m);

int main() {
    solveE5c_MonthlyExpense();
}

short budget[MAX_N];
void solveE5c_MonthlyExpense() {
    int n, m;
    scanf("%d %d", &n, &m);

    int sum = inputBudget(budget, n);

    int l = 0, r = sum, mid = (l + r) / 2, ans;
    while (l <= r) {
        if (!inRed(budget, n, mid, m)) {
            ans = mid;
            r = mid - 1;
        } else {
            l = mid + 1;
        }
        mid = (l + r) / 2;
    }

    printf("%d\n", ans);
}

int inputBudget(short budget[], int n) {
    int sum = 0;
    for (int i = 0; i < n; ++i) {
        scanf("%d", &budget[i]);
        sum += budget[i];
    }

    return sum;
}

bool inRed(short budget[], int n, int monthBudget, int m) {
    int cnt = 1, current = 0;
    for (int i = 0; i < n; ++i) {
        if (budget[i] > monthBudget)
            return true;
        current += budget[i];
        if (current > monthBudget) {
            ++cnt;
            current = budget[i];
        }
    }

    if (cnt > m)
        return true;
    else
        return false;
}