POJ 2456. Aggressive cows

1. 题目

http://poj.org/problem?id=2456

Aggressive cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8456 Accepted: 4224

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,…,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don’t like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended.

Source

2. 思路

牲口棚里有N个畜栏排成一行,畜栏位置为x1,…,xN,要把有C头牛安排到N个畜栏里(2 <= C <= N),每个畜栏只能安放一头牛,要求两头牛之间的距离尽可能远,求C头牛之间最短距离的最大值。
对畜栏位置进行排序后,对最短距离进行二分搜索。

3. 代码

#include <stdio.h>
#include <stdlib.h>

#define MAX_N 100000

void solveE5B_AggressiveCows();
void inputPositions(int pos[], int n);
int cmp(const void *a, const void *b);
bool isSafe(int pos[], int n, int dist, int target);

int main() {
	solveE5B_AggressiveCows();
}

int positions[MAX_N];
void solveE5B_AggressiveCows() {
	int n, c;
	scanf("%d %d", &n, &c);

	inputPositions(positions, n);

	int l = 0, r = positions[n - 1], mid = (l + r) / 2;
	while (l <= r) {
		if (isSafe(positions, n, mid, c)) {
			l = mid + 1;
		} else {
			r = mid - 1;
		}
		mid = (l + r) / 2;
	}

	printf("%d\n", mid);
}

void inputPositions(int pos[], int n) {
	for (int i = 0; i < n; ++i) {
		scanf("%d", &pos[i]);
	}
	qsort(pos, n, sizeof(int), cmp);
}

int cmp(const void *a, const void *b) {
	return (*(int *)a - *(int *)b);
}

bool isSafe(int pos[], int n, int dist, int target) {
	int cnt = 1, start = pos[0];
	for (int i = 1; i < n; ++i) {
		if (pos[i] - start >= dist) {
			start = pos[i];
			++cnt;
		}
	}

	if (cnt >= target)
		return true;
	else
		return false;
}