POJ 3259. Wormholes

1. 题目

http://poj.org/problem?id=3259

Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 36967 Accepted: 13562

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself 🙂 .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1..F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

Source

2. 思路

农场闹虫灾,给出若干条路,和若干个虫洞,走路会消耗时间,走虫洞会回溯时间。求从某一点出发,经过若干条路和虫洞,能否返回原处并穿越回出发之前的时间。
Bellman Ford求负权环。

3. 代码

#include <stdio.h>

#define MAX_N 501
#define MAX_M 2501
#define MAX_W 201
#define INF 10000

typedef struct EdgeRecord {
    int src, dest, weight;
} Edge;

void solvePoj3259_Wormhole();
void inputEdge(Edge edges[], int pathNum, int wormNum);
void setEdge(Edge *edge, int src, int dest, int weight);
bool bellmanford(Edge edges[], int vNum, int eNum);

int main() {
    int testNum;
    scanf("%d", &testNum);

    while (testNum--) {
        solvePoj3259_Wormhole();
    }
}

Edge edges[MAX_M * 2 + MAX_W];
void solvePoj3259_Wormhole() {
    int n, m, w;
    scanf("%d %d %d", &n, &m, &w);

    inputEdge(edges, m, w);
    if (bellmanford(edges, n, m + w)) {
        printf("NO\n");
    }
    else {
        printf("YES\n");
    }
}

void inputEdge(Edge edges[], int pathNum, int wormNum) {
    int src, dest, weight, cnt = 0;

    for (int i = 0; i < pathNum; ++i) {
        scanf("%d %d %d", &src, &dest, &weight);
        setEdge(&edges[cnt++], src, dest, weight);
    }

    for (int i = 0; i < wormNum; ++i) {
        scanf("%d %d %d", &src, &dest, &weight);
        setEdge(&edges[cnt++], src, dest, -weight);
    }
}

void setEdge(Edge *edge, int src, int dest, int weight) {
    edge->src = src;
    edge->dest = dest;
    edge->weight = weight;
}

int dist[MAX_N];
bool bellmanford(Edge edges[], int vNum, int eNum) {
    for (int i = 0; i <= vNum; ++i) {
        dist[i] = INF;
    }
    dist[1] = 0;

    for (int i = 0; i < vNum - 1; ++i) {
        for (int j = 0; j < eNum; ++j) {
            int src = edges[j].src, dest = edges[j].dest, weight = edges[j].weight;
            if (dist[dest] > dist[src] + weight) {
                dist[dest] = dist[src] + weight;
            }
            if (weight >= 0 && dist[src] > dist[dest] + weight) {
                dist[src] = dist[dest] + weight;
            }
        }
    }

    for (int j = 0; j < eNum; ++j) {
        int src = edges[j].src, dest = edges[j].dest, weight = edges[j].weight;
        if (dist[dest] > dist[src] + weight) {
            return false;
        }
        if (weight >= 0 && dist[src] > dist[dest] + weight) {
            return false;
        }
    }

    return true;
}