UVA 11292. Dragon of Loowater

1. 题目

https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=2267

Once upon a time, in the Kingdom of Loowater, a minor nuisance turned into a major problem. The shores of Rellau Creek in central Loowater had always been a prime breeding ground for geese. Due to the lack of predators, the geese population was out of control. The people of Loowater mostly kept clear of the geese. Occasionally, a goose would attack one of the people, and perhaps bite off a finger or two, but in general, the people tolerated the geese as a minor nuisance. One day, a freak mutation occurred, and one of the geese spawned a multi-headed fire-breathing dragon. When the dragon grew up, he threatened to burn the Kingdom of Loowater to a crisp. Loowater had a major problem. The king was alarmed, and called on his knights to slay the dragon and save the kingdom. The knights explained: “To slay the dragon, we must chop off all its heads. Each knight can chop off one of the dragon’s heads. The heads of the dragon are of different sizes. In order to chop off a head, a knight must be at least as tall as the diameter of the head. The knights’ union demands that for chopping off a head, a knight must be paid a wage equal to one gold coin for each centimetre of the knight’s height.” Would there be enough knights to defeat the dragon? The king called on his advisors to help him decide how many and which knights to hire. After having lost a lot of money building Mir Park, the king wanted to minimize the expense of slaying the dragon. As one of the advisors, your job was to help the king. You took it very seriously: if you failed, you and the whole kingdom would be burnt to a crisp!

Input

The input contains several test cases. The first line of each test case contains two integers between 1 and 20000 inclusive, indicating the number n of heads that the dragon has, and the number m of knights in the kingdom. The next n lines each contain an integer, and give the diameters of the dragon’s heads, in centimetres. The following m lines each contain an integer, and specify the heights of the knights of Loowater, also in centimetres. The last test case is followed by a line containing ‘0 0’.

Output

For each test case, output a line containing the minimum number of gold coins that the king needs to pay to slay the dragon. If it is not possible for the knights of Loowater to slay the dragon, output the line ‘Loowater is doomed!’.

Sample Input

2 3 5 4 7 8 4 2 1 5 5 10 0 0

Sample Output

11

Loowater is doomed!

2. 思路

m个骑士砍一只有n个头的龙,给出n个龙头的直径和m个骑士的身高,每个骑士只能砍直径不大于自己身高的龙头,每人最多只能砍一个龙头,砍后需支付等同于其身高的费用。求能否把龙头都砍完,如果可以,求最少花费。

升序排列龙头直径和骑士身高,对每个龙头,寻找身高大于等于该龙头直径,且身高最小的骑士,砍掉龙头,累加费用。如果有龙头无法砍掉,则直接失败;遍历完所有龙头,所得费用即为最少花费。

3. 代码

#include <stdio.h>
#include <stdlib.h>

#define MAX_HEAD_NUM 20001

void solveE4e_DragonOfLoowater(int headNum, int knightNum);
int cmp(const void *a, const void *b);

int main() {
    int headNum, knightNum;
    
    scanf("%d %d", &headNum, &knightNum);
    while (headNum != 0 || knightNum != 0) {
        solveE4e_DragonOfLoowater(headNum, knightNum);
        scanf("%d %d", &headNum, &knightNum);
    }

    return 0;
}

int heads[MAX_HEAD_NUM], knights[MAX_HEAD_NUM];
void solveE4e_DragonOfLoowater(int headNum, int knightNum) {
    for (int i = 0; i < headNum; ++i) {
        scanf("%d", &heads[i]);
    }
    
    for (int i = 0; i < knightNum; ++i) {
        scanf("%d", &knights[i]);
    }
    
    qsort(heads, headNum, sizeof(int), cmp);
    qsort(knights, knightNum, sizeof(int), cmp);
    
    int i, j = 0, cost = 0;
    bool killed = false;
    for (i = 0; i < headNum; ++i) {
        killed = false;
        for (; j < knightNum; ++j) {
            if (heads[i] <= knights[j]) {
                cost += knights[j];
                killed = true;
                ++j;
                break;
            }
        }
        if (!killed) {
            printf("Loowater is doomed!\n");
            return;
        }
    }
    
    printf("%d\n", cost);
}

int cmp(const void *a, const void *b) {
    return *((int *)a) - *((int *)b);
}